TOPIC: Tuner doesn't work

Tuner doesn't work 7 months 1 week ago #22475

Hello!

The tuner in my S-gear doesn't work at all. I am using Midi Guitar as plugin host and it says when scanning for plugins it can't load some plugins, which includes a tuner file - see attachment.
Is there an interference with Midi Guitar which also contains a tuner?

Greetings, Hans
Attachments:
Last edit: 7 months 1 week ago by Hans_g.
SIGN-IN TO REPLY

Tuner doesn't work 7 months 6 days ago #22480

I personally wouldn't rely on MidiGuitar being a great plugin host. I would instead use MidiGuitar as a plugin in a DAW or other plugin host and keep S-Gear separate.

But I can confirm on MacOS that the S-Gear tuner doesn't work in MidiGuitar2 when using the VST3 version of S-Gear (also the input/output LED indicators don't work). But the AU version of the plugin works fine.

If you are using the VST3 version, can you try the standard VST2 version of S-Gear. Otherwise, the inbuilt PolyTuner in MidiGuitar is fine, as is other tuners like the free MTuner from Melda.
The following user(s) said Thank You: Hans_g
  • kierank
  • kierank's Avatar
  • Offline
  • Tone Master
  • Posts: 302
SIGN-IN TO REPLY

Tuner doesn't work 7 months 5 days ago #22482

Hans_g wrote:

Hello!

The tuner in my S-gear doesn't work at all. I am using Midi Guitar as plugin host and it says when scanning for plugins it can't load some plugins, which includes a tuner file - see attachment.
Is there an interference with Midi Guitar which also contains a tuner?

Greetings, Hans

As kierank suggests, with this host it would be better to use the S-Gear VST2.

The host is scanning all the files in the VST3 plug-in package, whereas it should only scan files in the correct executable folder of the VST3 package. Older VST2 and VST3 plug-ins will scan OK since they are a single library file rather than a package (with subfolders).

The other problem pointed out by kierank (where the meters and tuner do not work) is because the host is not implementing output parameters as per the VST3 specification. The live information is thus not getting back to the GUI. You may find that many plug-ins work fine in this respect, this is because they use a VST3 wrapper which doesn't use the VST3 framework for sending data back to the interface.
The following user(s) said Thank You: Hans_g
  • mike
  • mike's Avatar
  • Offline
  • Administrator
  • Posts: 2099
SIGN-IN TO REPLY
Time to create page: 0.065 seconds
Powered by Kunena Forum