TOPIC: S-GEAR and MacOS 10.15 Catalina (UPDATED)

S-GEAR and MacOS 10.15 Catalina (UPDATED) 5 months 3 weeks ago #20266

Apple's next MacOS update 10.15 is due for release this Autumn and currently in Beta.

S-GEAR v2.71 has been released to address a crash on start-up under MacOS 10.15.
S-GEAR v2.70 is NOT compatible with Catalina.

Please take note before installing the Apple public Beta or the final release when it becomes available:

S-GEAR v2.7 does not officially support MacOS 10.15 at this time.

Mike

(updated 13th Sept 2019)
The following user(s) said Thank You: fatherjacques, orda3000, ges, ross, Wellreel
  • mike
  • mike's Avatar
  • Offline
  • Administrator
  • Posts: 1929
Last edit: 3 months 4 weeks ago by mike. Reason: remove the 'X'
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina 5 months 2 weeks ago #20304

Good call Mike, I was just about to try the Catalina Beta not more than a few minutes ago! I use S-Gear a lot and would hate to lose it because of an Apple upgrade! Sometimes software developers have a hard time keeping up with the times, however people like myself can't afford to lose time when studio time is expensive. Many of my clients like using S-Gear as an alternative to stomp peddles and other types of foot processors, so your news is good! Thanks Mike for your post! rocknrider
The following user(s) said Thank You: mike
  • rocknrider
  • rocknrider's Avatar
  • Offline
  • Tone Seeker
  • Posts: 1
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina 5 months 2 weeks ago #20321

rocknrider wrote:

Good call Mike, I was just about to try the Catalina Beta not more than a few minutes ago! I use S-Gear a lot and would hate to lose it because of an Apple upgrade! Sometimes software developers have a hard time keeping up with the times, however people like myself can't afford to lose time when studio time is expensive.

Absolutely. It is very difficult to provide early assurances about new OS releases, especially with plug-ins that are also dependent on the host DAW software being compatible too. Best to wait a few months then check with your key software developers before upgrading.

The v2.71 release addresses an obvious crash on start-up under Catalina. Hopefully this will provide a solution for anyone who must update.
The following user(s) said Thank You: alexanderpopov
  • mike
  • mike's Avatar
  • Offline
  • Administrator
  • Posts: 1929
Last edit: 5 months 2 weeks ago by mike.
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina (UPDATED) 5 months 2 weeks ago #20323

I'm getting a lot of manufacturers notices from various plug-ins I own saying don't update to macOS 10.15 Catalina at this time. Changes were made to Core Audio, etc. So best to hold off for awhile....
"Before you criticize someone, you should walk a mile in their shoes. That way when you criticize them, you're a mile away and you have their shoes." - Jack Handey
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina (UPDATED) 5 months 1 week ago #20334

Thanks Mike - This 2.71 release seems to be working well on 10.15!

I've been using 10.15 to mess around with SwiftUI etc and have just been using Garageband amps for a couple of months so this update is vastly appreciated!
The following user(s) said Thank You: mike, hoss
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina (UPDATED) 4 months 2 weeks ago #20408

Installed OSX Catalina 10 15, S-Gear crashed.
I Trashed the plist, reinstalled I Lok S-Gear.
Works fine so far for MainStage, Waveform 10 Pro, Logic X, and standalone.
Last edit: 4 months 2 weeks ago by Squish1.
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina (UPDATED) 4 months 2 weeks ago #20409

Squish1 wrote:

Installed OSX Catalina 10 15, S-Gear crashed.
I Trashed the plist, reinstalled I Lok S-Gear.
Works fine so far for MainStage, Waveform 10 Pro, Logic X, and standalone.

Which version of S-Gear are you using?
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina (UPDATED) 4 months 1 week ago #20416

I'm a complete new user of S-gear ( installed 2.71 2 months ago on a brand new I-mac with Mojave and upgraded to Catalina 10.15 last weekend)

I can confirm the solution of Squish1 after having the same problems.

With latest Catalina update Yesterday 10 PM (dutch time) :
Trash Info.plist, uninstalled ILok License Manager - reinstalled the existing ILOK License Manager Package and reinstalled S-gear 2.71. Standalone version and Logic X plugin worked fine afterwards
SIGN-IN TO REPLY

S-GEAR and MAC OSX 10.15 Catalina (UPDATED) 2 months 11 hours ago #20684

I am on my way to buy a new Imac (currently using a MacBook Pro with Mojave). A new IMac comes with Catalina installed, I know all the warnings... I use Logic as DAW. What do I have to do after purchase to get S-Gear working?
SIGN-IN TO REPLY
Time to create page: 0.075 seconds
Powered by Kunena Forum